Faulty Switch

Discussion in 'General TomTom Discussion' started by jaspurr, Dec 31, 2007.

  1. jaspurr

    jaspurr

    Joined:
    Dec 31, 2007
    Messages:
    1
    Likes Received:
    0
    Since receiving my 920T in mid December I found a fault immediately in that it keep switching itself on after shutdown and depletes the battery so when you come to switch it back on with no car/ mains power it is dead. Has anyone else had any similar problems?

    I am just off to the store to return it and get a refund and I will need to think before I replace it with another though as I have bought all the car attachments and cases sepetrately I don't think I will have a choice. Besides they have dropped the price by ?80 ($160'sh) so I will also make a saving.

    I am wondering if the 720 would do what I require as I have an incar hands free kit for my phone. Mmmm, looks like I will need to study the forums in detail when I get back.
     
    Last edited: Dec 31, 2007
    jaspurr, Dec 31, 2007
    #1
    1. Advertisements

  2. jaspurr

    mfsunshine

    Joined:
    Dec 28, 2007
    Messages:
    24
    Likes Received:
    1
    Location:
    Huntington Beach, CA
    TomTom Model(s):
    920
    I've been having the same problem. I shut it off and stick it the case, put it in my backpack, only to hear a strange voice coming from my backpack a few minutes later. It does it sporadically. Any ideas out there?
     
    mfsunshine, Jan 1, 2008
    #2
    1. Advertisements

  3. jaspurr

    infama

    Joined:
    Aug 6, 2007
    Messages:
    210
    Likes Received:
    11
    Does a reset cure this?
     
    infama, Jan 2, 2008
    #3
  4. jaspurr

    mfsunshine

    Joined:
    Dec 28, 2007
    Messages:
    24
    Likes Received:
    1
    Location:
    Huntington Beach, CA
    TomTom Model(s):
    920
    No it does not.
     
    mfsunshine, Jan 9, 2008
    #4
  5. jaspurr

    mfsunshine

    Joined:
    Dec 28, 2007
    Messages:
    24
    Likes Received:
    1
    Location:
    Huntington Beach, CA
    TomTom Model(s):
    920
    Any news or updates regarding this issue out there?
     
    mfsunshine, Jan 21, 2008
    #5
  6. jaspurr

    infama

    Joined:
    Aug 6, 2007
    Messages:
    210
    Likes Received:
    11
    Do you have the tight fitting case?

    It has been reported elsewhere that the official case is too tight and depresses the on switch!

    Use a different case! My $5 Denali case from Target has no problems at all.
     
    infama, Jan 22, 2008
    #6
  7. jaspurr

    mfsunshine

    Joined:
    Dec 28, 2007
    Messages:
    24
    Likes Received:
    1
    Location:
    Huntington Beach, CA
    TomTom Model(s):
    920
    Initially I thought that might be the problem, but it has done it sitting on a table top with nothing around it. You turn it off and 5-10 seconds later... it's booting up again.
     
    mfsunshine, Jan 22, 2008
    #7
  8. jaspurr

    infama

    Joined:
    Aug 6, 2007
    Messages:
    210
    Likes Received:
    11
    Return it for a new one. That is a manufacturer fault.
     
    infama, Jan 22, 2008
    #8
  9. jaspurr

    mfsunshine

    Joined:
    Dec 28, 2007
    Messages:
    24
    Likes Received:
    1
    Location:
    Huntington Beach, CA
    TomTom Model(s):
    920
    Back to Costco it went...
     
    mfsunshine, Feb 6, 2008
    #9
  10. jaspurr

    PhunkyDork

    Joined:
    Jan 9, 2008
    Messages:
    9
    Likes Received:
    0
    This is happening to a number of units. Call TomTom and watch as they act like they've never heard of it, then direct them to this forum. "Hmmm.... I don't have a good lie for you"
     
    PhunkyDork, Feb 12, 2008
    #10
  11. jaspurr

    MooseLoad

    Joined:
    Feb 14, 2008
    Messages:
    9
    Likes Received:
    1
    I had this problem with my new 920, and I think I found the cure. I first noticed it when I was playing with the options and chose the battery saving option to turn off the device when external power is lost. When I chose that option, the unit kept turning itself back on! I went back in and de-selected that option and it stayed off. A couple days later I went back in to try it again, and sure enough it would turn itself back on when that option is selected.
    Try this and let me know if yours does the same....maybe its just a software bug they can address....
     
    MooseLoad, Feb 14, 2008
    #11
  12. jaspurr

    Kendall

    Joined:
    Apr 8, 2008
    Messages:
    10
    Likes Received:
    0
    Hi...

    This has been "solved" with the new, 7.480 OS update. There are more recent posts that deal with this. I tried really everything, but only the newest OS did the trick. Now the 920 works as it should.
     
    Kendall, Apr 9, 2008
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.