error when trying to update gps fix data.

Jul 24, 2010
Ronkonkoma NY
TomTom Model(s)
XL 335 S, Via 1535TM
After installing latest version of Home (on 2011 Mar 20), when went to "update", I got an error message during the the ephem update. "Item was not valid after installation." The :\ephem folder on the TT has an ee_meta.txt file and no other file.

If I try to use Add traffic, voices... etc > items on my comptuer > quick gps fix data, to copy the latest ephemeris data to my TT, I get the same error message. Even if I erase the ee_meta.txt file first. Even if I erase (change the name) of the lastes gps data on my computer, and use Add traffic voices to try and copy the next to latest gps data (which I had used previously and which worked previouslY) I still get the same error message.

Rebooting my computer did not help.


Use Explorer to delete everything in the ephem folder on the unit AND delete all the subfolders you find in the ephemeris folder here:
C:\Documents and Settings\yourname\My Documents\TomTom\HOME\Downloads\complete\ephemeris\

Then connect to Home and see if a new gpsquickfix file works better when installed.

Use Update my Unit to get the file.
dhn I tried that already. Deleted everything in the x:\ephem folder on the the unit, and deleted the latest folder in C:\Documents and Settings\[username]\My Documents\TomTom\HOME\Downloads\complete\ephemeris \. With the this latest folder deleted, Add traffic, voices... etc cued up the next to the latest version of gps fix to be copied from the computer to the TT - the version which I had previously been using successfully. But I got the same error message when I tried use add traffic, etc to install that version of ephem: "item not valid after installation" Same message I got when I tried to use update my device to update the ephemeris data.
Oh, wait a minute. I deleted (renamed, really) the entire set of username ephemeris folders on my computer, and then I was able to update ephem on my TT, using update my device. This worked even tho trying to update from my computer, using add traffic... etc), with a known working version of ephemeris, didn't work. Not sure why.
Last edited:
Home, of course, made a new ephemeris folder on my computer, with just a single gpsquickfix subfolder. I still have gpsquickfix-1 thru gpsquickfix-56 on my computer, in the (renamed) but I don't know what I am saving these outdated databases for.
Last edited:
But now, weirdly, when I click update my device I get the same error message. At least it leaves the most recent ephem files in place on the TT, even tho it insists that they are not valid.


Ok, after, in Home, I clicked device > disconnect device, then I unplugged and replugged my TT and reconnected to my computer - now Update my device is no longer giving and error message. Just a "no items available" message.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question