Email Address for Customer Support in the USA?

Joined
Jun 27, 2009
Messages
17
Location
Rochester, NY
TomTom Model(s)
140S
Does anyone know an email address that I can use to contact United States customer support? For various reasons it's difficult for me to call customer support. I have tried to use the TomTom web site to submit a question, but there is a bug in their site and it keeps looping me through login/FAQ/renter my information screens. I have tried this with two web browsers (Internet Explorer and Firefox) and have the same problem with both.

Thanks!
/Don
 
Go to this link and go through the steps of picking your product, etc.

Eventually, you'll get to the form to fill out your query and be able to submit the question. Not an email address as such, but you are actually emailing the question to them.

Strongly suggest you do find a way to call, though as it has proved much more effective at getting responses from Support.

866-486-6866.
 
I guess that I was not clear. The procedure that you provided is exactly what I did and instead of giving me the form to submit a question it bounced me back to step one. Multiple times. Using two different web browsers (Internet Explorer and Firefox).

Thanks for the advise to call TomTom.

/Don
 
Did you log into TT with your account id first? (email address/password).

Yes. In fact, I was prompted for this information every time that I was cycled through the infinite loop.

It's definitely a web site bug. I see this type of thing almost everyday as part of my job.

/Don
 
I just tried it again.

In step 3, select an item in the drop down menu (like 'maps'). Then scroll to the bottom where the 'contact us' link is. Fill in some info and you'll see some possible solutions but there is a button at the bottom to carry on submitting the question. Have you gotten that far?
 
I just tried it again.

In step 3, select an item in the drop down menu (like 'maps'). Then scroll to the bottom where the 'contact us' link is. Fill in some info and you'll see some possible solutions but there is a button at the bottom to carry on submitting the question. Have you gotten that far?

So did I, and I still get stuck in the infinite loop. So I called TomTom, and they confirmed that I am doing everything correctly and that there is a problem with their web site that is affecting me, but perhaps not all users. My account data may be corrupt or something (the tech person was speculating - this area was not her specialty).

Anyway, there is no need to continue to try to help me use their web site. Calling tech support was very helpful (thanks for suggesting that) and I am all set.

/Don
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
29,146
Messages
197,060
Members
68,199
Latest member
Boothy

Latest Threads

Back
Top