Eclipse AVN2210p

Discussion in 'General TomTom Discussion' started by Paulie B., Jan 15, 2008.

  1. Paulie B.

    Paulie B.

    Joined:
    Jan 15, 2008
    Messages:
    3
    Likes Received:
    0
    i have a Eclipse AVN2210p and i started to loose map detail. So I decided to update my maps and register my product using the TomTom home. I let the TomTom home updated everything, I was excited to pop the unit back into my car and check out the new updates.

    "No Maps Found"

    Now im stuck and i don?t know what to do, i have read about 10 threads on this problem and i have tried pretty much all of them.

    When i have my TT hooked up to the PC(my tomtom) i can see the maps are on the TT's hard drive, but it just wont read them when i turn the device on

    I also deleted the Guam map, and i think this is where my problem started.

    Another question,, is there a USA TomTom support line i can call?

    I think I may be on to solving this problem, I read in a certain thread that says there is a way to rename the maps so the TT can recognize them, does this sound familiar?
    BTW, I didn?t have a chance to back up my TT when it first updated everything.

    If i decided to buy the USA map will i have the same problem?
     
    Paulie B., Jan 15, 2008
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.