Eclipse AVN2210p CD read error, unit now stuck in tilt position

Discussion in 'General TomTom Discussion' started by djc9, Jan 25, 2008.

  1. djc9

    djc9

    Joined:
    Jan 25, 2008
    Messages:
    2
    Likes Received:
    0
    I've had my Eclipse AVN2210p for a few months now with no issues. A couple days ago the CDP stopped midway through a track and while I could browse to other tracks the CD did not seem to be reading. I tried to eject by pushing the tilt button and the unit tilted down as normal but the CD did not eject.

    The unit then switched to the tuner and is stuck in the extreme tilt position. The volume control works, but every other button is non-functioning so I cannot switch stations or settings but most importantly I cannot get the unit to move out of the extreme tilt position. The TomTom still powers up when docked and the gps functions as normal but without any functionality from the headunit.

    Any ideas? Can't find any documentation on how to troubleshoot this type of problem on the web for the AVN2210p nor searching on this forum. I should probably take it back to firedog but I had an awful experience there with my install so if I want to avoid that if at all possible.

    Thanks in advance if anyone has suggestions.
     
    djc9, Jan 25, 2008
    #1
    1. Advertisements

  2. djc9

    Birdman

    Joined:
    Dec 9, 2007
    Messages:
    778
    Likes Received:
    87
    Location:
    Jericho, VT
    TomTom Model(s):
    TomTom Go 920

    Eclipse units typically have a pin-hole RESET button...have you tried to RESET the unit with a paper clip? Many have this RESET button on the front of the unit hidden by the face....since your face is already open, the hold should be visable.
     
    Birdman, Jan 25, 2008
    #2
    1. Advertisements

  3. djc9

    djc9

    Joined:
    Jan 25, 2008
    Messages:
    2
    Likes Received:
    0
    Thanks, that did the trick.
     
    djc9, Jan 25, 2008
    #3
  4. djc9

    N715DP

    Joined:
    Oct 29, 2007
    Messages:
    77
    Likes Received:
    3
    TomTom Model(s):
    TomTom Eclipse
    be careful on this one... my first 2210 did the same thing... the optical drive in the unit does NOT handle read-errors well (scratches, bad burns...). As a result, if it comes up on one it can't get past it basically crashes out the whole thing - if you hold the eject button for about 20 seconds, it will open and SOMETIMES spit out the disc - usually it won't.

    I put up with it for about a month and then returned mine to the shop that installed it - they called Eclipse and got an RMA and swapped it with one they had in stock that same day (good customer service after the sale by these guys).

    For me, it started right after I got the unit. The first MP3 disc that I put in was a bad burn and crapped out. Then, about 3 weeks after I got it, it locked up about 2 hours into our drive to Maine (11 hour drive) and I had no navigation or music for the rest of the way there, or the way back - not fun, but oh well.

    The replacement has been in place since August and it's worked like a champ - even with the discs that the other one failed on. This leads me to believe that some of the early-produced units after it went on sale in June were bad - perhaps an entire production run.

    Just my experience to help you along.
     
    N715DP, Jan 27, 2008
    #4
  5. djc9

    mpshelangoski

    Joined:
    Dec 21, 2008
    Messages:
    2
    Likes Received:
    0
    I have the same problem randomly... did you find a solution to this issue?
     
    mpshelangoski, Dec 21, 2008
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.