Application Version 8.414 for the 140S?

Jun 27, 2009
Rochester, NY
TomTom Model(s)
TomTom Home installed 8.414 on my 140S this morning. I went to the indicated web site for more information, but 8.414 was not listed. Does anyone know what is new in this firmware?

Can someone confirm whether they can run the re-released map 830 on app 8.411?

The new map was released within days of 8.414. I wonder if 8.414 contained enhanced compression technology to read the map?
Last edited:
I don;t know for sure. After I upgraded the application to 8.414, TomTom Home said that a new map was available. I tried to install the new map, but it failed and now my 140s has no maps *and* is not recognized by my computer as a valid USB device. When I get time later this afternoon, I am going to try to reset the unit and then go from there.

Yes, do a reset on the unit (I think your model needs a holding of the power button for 15 seconds or so). If the unit is recognized by Windows AND if the new map was downloaded, we can tell you how to install without using Home.
The good news is that the soft reset plus rebooting my computer solved the problem where Windows did not recognize the TomTom as a USB device. The bad news is that the unit still says that there is no map installed. I found the zip file containing the new map on my computer, so hopefully I can install it manually (without using Home).

What do I need to do to install the new map?

Thanks for the instructions. For what it's worth, the map on my PC was in a zip file, not a cab file. But it's seems pretty clear how to adapt those instructions for this case.

I wasn't able to use those instructions, because every time that I tried to copy the map it failed after a short period of time. I finally concluded that I may have a file system problem, so I reformatted the 140s HD. But that did not solve the problem, because I then found that I still experienced failures when I tried to copy the application back onto the 140s. I ended up powering off/on the 140s, connected to a different USB port on my PC, then I used Home to successfully install the new application and the new map.

After that I found that the 140s did not contain any voices, but again Home seems quite happy to reinstall them.

All in all, it's been a painful coupld days, but everything seems to be working out fine. And thanks to this forum, I didn;t have to contact TomTom technical support!

I wonder if you hit the same issue I seemed to hit with my 340S. After 8.414 installed, I noticed that file copies (from Home and otherwise) would randomly stall. It literally took over 7 hours to copy the 830 map over because it would copy 2MB, stall for a minute, copy another couple MB, and so on. You might be seeing similar issues, and it isn't something I saw with 8.411.

I wound up doing an exchange because the file copy stalls was making the daily sync painful as heck, but that is a topic for another thread.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Latest member

Latest Threads