940 live - Stopped working and hot battery!

Discussion in 'Technical Support' started by SPINNER3775, Mar 25, 2013.

  1. SPINNER3775

    SPINNER3775

    Joined:
    Mar 25, 2013
    Messages:
    3
    Likes Received:
    0
    Location:
    KENT, U.K
    TomTom Model(s):
    940LIVE
    Help!!!

    My 940 live has stopped working and will come on when plugged into the computer. I thought it was the battery so i have bought one and replaced it.
    Once i replaced the battery and connected it the orange light comes on and stays on if this means anything.
    I thought the battery would be the fix.

    The unit is also hot and replacing the battery has not seemed to do anything!!!

    Any help appreciated.

    Spinner:roll:
     
    Last edited by a moderator: Apr 16, 2013
    SPINNER3775, Mar 25, 2013
    #1
    1. Advertisements

  2. SPINNER3775

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    23,130
    Likes Received:
    450
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    Have all functions stopped working? In other words, does the unit boot up? Or is it just Live Serves not working?
     
    dhn, Mar 25, 2013
    #2
    1. Advertisements

  3. SPINNER3775

    SPINNER3775

    Joined:
    Mar 25, 2013
    Messages:
    3
    Likes Received:
    0
    Location:
    KENT, U.K
    TomTom Model(s):
    940LIVE
    It turned on before I changed the battery but thgat was it now it wont do anything? but it is stiil hot so wondering if it its the battery?
     
    SPINNER3775, Mar 26, 2013
    #3
  4. SPINNER3775

    Andy_P Moderator

    Joined:
    Feb 11, 2011
    Messages:
    4,683
    Likes Received:
    36
    Location:
    London, UK.
    TomTom Model(s):
    Go520,720,XL Live, Start60,Go940,950,1000,1005,New500,New5000
    I would try switching back to the original battery ASAP.

    Get rid of that dangerous-sounding heat first, and then work on the other problems!
     
    Andy_P, Mar 26, 2013
    #4
  5. SPINNER3775

    SPINNER3775

    Joined:
    Mar 25, 2013
    Messages:
    3
    Likes Received:
    0
    Location:
    KENT, U.K
    TomTom Model(s):
    940LIVE
    Any ideas what the heat could be and why I havent had it before?
     
    SPINNER3775, Apr 15, 2013
    #5
  6. SPINNER3775

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    11,205
    Likes Received:
    201
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720, GO740TM Live, GO 1535 Live, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, TomTom Bridge
    You'll want to find out with the case open, but having opened the case and connected to USB, quickly determine by touch if it is the battery that is getting hot. If so, disconnect from the power source IMMEDIATELY and shut the unit off if necessary.

    Then, as Andy suggests, try the other battery (even though in poor condition) to see whether or not the same occurs.

    Let's start from there. Your replacement may be defective, or your TomTom may have killed it.
     
    canderson, Apr 15, 2013
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.