720 Turning on by itself


Joined
Dec 11, 2007
Messages
208
Location
Pittsburgh Pa USA
TomTom Model(s)
TomTom 720
Why is my 720 turning on all by itself. It never did this before. I have a older map with 8.1 navcore or the first version of the 8 series with lane assist there but not available. It keeps running my battery dead.
 
Ad

Advertisements

Joined
Sep 20, 2008
Messages
1,018
Location
Tampa, FL USA
TomTom Model(s)
GO 720
Why is my 720 turning on all by itself. It never did this before. I have a older map with 8.1 navcore or the first version of the 8 series with lane assist there but not available. It keeps running my battery dead.
I had this same issue 2 weeks ago. What I did to fix this was, I backed up my unit using Windows Explorer, then did a FULL format (not quick) on my SD card AND internal memory, then I let the Home software install everything to my device from scratch. Home will reinstall NavCore and your map onto your device. Haven't had a problem since. Corrupt files can cause this to happen.
 
Ad

Advertisements

Joined
Mar 19, 2008
Messages
71
Why is my 720 turning on all by itself. It never did this before. I have a older map with 8.1 navcore or the first version of the 8 series with lane assist there but not available. It keeps running my battery dead.
I have both a 920 and 930 that were doing this every few days until the 8.3 update, since then it has not happened once. I can't guarantee that this will be a cure for you, and I know some people have had problems with it, but it's really improved things for me, without any noticeable issues.
John
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top