New via 130 not charging

Discussion in 'Hardware and Peripherals' started by Xanderzdad, Nov 20, 2012.

  1. Xanderzdad

    Xanderzdad

    Joined:
    Nov 20, 2012
    Messages:
    4
    Location:
    United Kingdom
    TomTom Model(s):
    via 130
    Hi, I have a brand new Tomtom Via 130 and it will not charge from my PC or the supplied car USB charger.

    Is there anything I can try before returning it?
    Thanks
     
    Xanderzdad, Nov 20, 2012
    #1
    1. Advertising

  2. Xanderzdad

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    21,171
    Location:
    Toronto Canada
    TomTom Model(s):
    720; 540; 1535 LIVE; Via 1605
    When you connect the device to the computer, does it show a little computer symbol on the screen or a battery? Also, when connecting using the car charger, is it showing a battery on the screen?

    Also, are you sure you've inserted the micro usb plug completely into the unit? It can be a bit of a tight fit.
     
    dhn, Nov 20, 2012
    #2
    1. Advertising

  3. Xanderzdad

    Xanderzdad

    Joined:
    Nov 20, 2012
    Messages:
    4
    Location:
    United Kingdom
    TomTom Model(s):
    via 130
    It shows the little computer symbol on the screen but not a battery icon and all updates work. It also operates fine if plugged into power.
    In the settings it always says it is on battery power with 0% charge and it switches off as soon as it is unplugged from power.
     
    Xanderzdad, Nov 20, 2012
    #3
  4. Xanderzdad

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    8,536
    Location:
    Colorado
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA130
    If it consistently operates correctly when plugged into power, but refuses to charge, I'm afraid you'll be needing to take that one back to the store for a swap. Sounds like it came with a defective battery or charging circuit (probably the former).
     
    canderson, Nov 20, 2012
    #4
  5. Xanderzdad

    Xanderzdad

    Joined:
    Nov 20, 2012
    Messages:
    4
    Location:
    United Kingdom
    TomTom Model(s):
    via 130
    Thanks - on it's way back to Amazon
     
    Xanderzdad, Nov 20, 2012
    #5
  6. Xanderzdad

    Freecell49

    Joined:
    Nov 28, 2012
    Messages:
    2
    Location:
    UK
    TomTom Model(s):
    Via 130 Europe
    Just had exactly the same problem and sending mine back to Amazon too. Suspect manufacturing batch?
     
    Freecell49, Nov 28, 2012
    #6
  7. Xanderzdad

    Xanderzdad

    Joined:
    Nov 20, 2012
    Messages:
    4
    Location:
    United Kingdom
    TomTom Model(s):
    via 130
    Probably - Amazon were brilliant. Emailed me labels etc to send back old one but dispatched a new one immediately so I was never without my satnav.
     
    Xanderzdad, Nov 28, 2012
    #7
  8. Xanderzdad

    Freecell49

    Joined:
    Nov 28, 2012
    Messages:
    2
    Location:
    UK
    TomTom Model(s):
    Via 130 Europe
    Have mine repackaged to go back and have another one on automatic re-order so hope that the replacement doesn't have the same fault. Agree about Amazon service being top class.

    Used the on-line chat with TomTom and they offered to repair but given it only arrived today decided a return was likely to be quickest way to get a fully functional unit. Fingers crossed
     
    Freecell49, Nov 28, 2012
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. russty

    PC Charging your ONE

    russty, Jan 22, 2007, in forum: General TomTom Discussion
    Replies:
    12
    Views:
    2,424
    digital-flex
    Aug 31, 2007
  2. Kim

    charging

    Kim, May 27, 2009, in forum: General TomTom Discussion
    Replies:
    1
    Views:
    544
  3. Piggie
    Replies:
    13
    Views:
    2,898
    Piggie
    Jul 6, 2009
  4. chuchucharlie

    Car charging help please!

    chuchucharlie, Jan 16, 2010, in forum: General TomTom Discussion
    Replies:
    2
    Views:
    728
    chuchucharlie
    Jan 17, 2010
  5. ldg2009

    xl iq charging when off

    ldg2009, Jan 31, 2011, in forum: General TomTom Discussion
    Replies:
    6
    Views:
    1,937
    pjten
    Feb 1, 2011
Loading...

Share This Page